Frischfisch

fish life reporting


Hinterlasse einen Kommentar

WIN7: Interner Fehler, Falscher Parameter 0x80070057

Viele Benutzer sind inzwischen sehr sensibel geworden was Backups betrifft. Wer einmal einen Datenverlust hatte weiß wie wichtig regelmäßige Backups sind. Es gibt auch den Satz „Backups sind für Feiglinge“… das geht oft nach hinten los wenn der Datenverlust erstmal eingetreten ist. Regelmäßige Sicherungen sparen einem im Nachhinein viel Ärger.

Bei Windows 7 kann es vorkommen das die Sicherung nicht mehr aufgerufen werden kann.

„Interner Fehler Falscher Parameter 0x80070057“ steht hinter einem roten Kreuz. Problem dabei ist, das ein Eintrag im System falsch gesetzt wurde bei Einrichtung dieser Sicherung. Die Datei c:\windows\system32\wbem\repository ist schuld. Benennt man die Datei um wird sie beim nächsten Neustart aufomatisch neu erstellt.

Behebung:

1. Starten Sie die Eingabeaufforderung als Administrator

Stoppen sie das Windows Management als Dienst mit:

– net stop winmgmt

Wenn Sie gefragt werden ob sie das Sicherheitscenter mit schließen wollen mit „j“ (JA)
Der Dienst wird beendet.

Benennen Sie jetzt folgende Datei um mit dem rename Befehl:

– ren c:\windows\system32\wbem\repository repository.old

Wenn die Datei umbenannt wurde starten Sie den Dienst wieder mit:

– net start winmgmt

Ist dies erfolgt starten Sie Windows neu.

Danach wird die Datei repository  im wbem Ordner neu erstellt.

Damit sollte die Windows Sicherung wieder funktionieren.

Advertisements


Ein Kommentar

Medion Akoya 1226 Netbook und Canon EOS Software…

… eine Kombination die auf normalen Wege nicht gelingen wird. Aldi verkauft seit letzten Sommer ein recht günstiges Netbook von Medion. Dieses Atom Netbook ist sicherlich keine Rakete, aber für kleinere Aufgaben ist dieses Netbook brauchbar. Der Leistungsindex unter dem vorinstallierten Windows 7 liegt bei knapp 2,4. Das ist wenig, aber ausreichend. Ich besaß ein JVC Subnotebook mit Windows XP und einem integriertem Pentium Prozessor was mir jahrelang sehr gute Dienste geleistet hatte. Nachdem das leider den Geist aufgegeben hat musste was neues her. Das JVC kostete mich damals ca. 1400 Euro. Dagegen ist das Netbook von Medion ein echtes Schnäppchen. Ok, das JVC war wesentlich wertiger verarbeitet, teilweise Aluminium. Das Akoya ist reines, hochglanzpoliertes Plastik und entsprechender pfleglicher muss ich damit umgehen.

Vorrangig brauchte ich einen transportablen Speicher, der neue SDHC Karten lesen kann und mir als Zwischenspeicher für meine Urlaubsfotos dient. Eine eingebaute 250Gb Festplatte sollte mir auch reichen als „Fotospeicher“. Ein integrierter USB3.0 Port stellt auch nochmal beschleunigte Performance bei externen Festplatten bereit. Für meine Zwecke also recht brauchbar. Bildbearbeitung ist auf Teil nicht lustig, aber funktioniert. Meine alte Photoshop Lizenz der Version 7 läuft reibungslos.

Dann kam mir die Idee meine Canon EOS 550D damit fernsteuern zu können. Die beiliegende Software von Canon kann das.

Kein DVD Laufwerk und noch viele andere Probleme bis zur erfolgreichen Installation

Womit das erste Problem zu lösen wäre, wenn man kein externes DVD Laufwerk mit USB Anschluss besitzt. Wie bekommen sie Zugriff auf die CD? Ganz einfach, über Netzfreigaben an einem anderen Rechner oder man kopiert sich auf einem Rechner mit Laufwerk die komplette CD auf einen USB Stick und installiert von dort aus. Bei mir muss mein Quadcore PC dafür herhalten. Der ist mit dem Netbook in einer gemeinsamen Arbeitsgruppe und so können die beiden sich die Freigaben teilen. Wie sowas realisiert wird, ist hier super erklärt. Ich lege also die CD in das DVD Laufwerk in meinem PC ein. Über den Explorer gebe ich das Laufwerk im Netzwerk frei und kann dann über die Netzwerkfreigabe am Akoya drauf zugreifen als wäre es ein internes Laufwerk. Super.

Die Canon Software startet und klatscht mir erstmal ein Popup ins Gesicht:

Erste Fehlermeldung.... entweder schließen sie jetzt einen externen Monitor an das Netbook oder bearbeiten die Windows Registrierung

Grrrrrrrr ….. das es Probleme geben würde hatte ich schon fast vermutet, aber schon so früh? Wenn Sie nun die Auflösung ändern wollen werden sie feststellen, daß die höchst mögliche Auflösung bei 1024 x 600px liegt. Eine höhere Auflösung kann nicht gewählt werden.

Ich weiß das die Win7 Starter Version nix anderes ist als eine Windows7 Home Version, die per Registrierung leicht kastriert ist. Also starten wir den Registrierungseditor und exportieren die Registrierungsdatei erstmal irgendwo auf ein Backup Laufwerk (falls was schiefgeht, können wir so den Rechner wieder „reparieren“)

Dann durchsuchen wir die Registrierung nach folgendem Schlüssel: „Display1_DownScalingSupported“

Dieser Schlüsselwert ist in der Registrierung 6 oder 7 mal enthalten. Setzen sie alle Dword Werte auf 1 (die Registrierung macht dann 0x0000001(1) draus). Danach müssen sie das Netbook neu starten und können dann in der Bildschirmauflösung (rechte Maustaste auf den Desktop „Bildschirmauflösung“ wählen die Auflösung auf 1024 x 768 pixel stellen. Das Problem ist dabei, daß die Anzeige nun gestaucht wird, da tatsächlich in der Höhe das Netbook nur 600 px darstellen kann. Das ist aber erstmal egal. Diesen Zustand müssen wir ja nur für die Installation herstellen und können die Auflösung später wieder auf den Ursprungszustand ändern. Dann ist alles wieder normal.

nach dem Bearbeiten des Registrierungsschlüssels stehen ihnen höhere Auflösungen zur Auswahl

Wenn sie nicht in der Registrierung rumspielen wollen (Anleitung) bzw. nicht wissen wie das geht dann können sie alternativ auch einen zweiten Monitor an das Netbook anschließen der automatisch eine höhere Auflösung bereitstellt.
Ohne externen Monitor müssen sie leider den Weg über die Registrierung wählen.

Greifen sie jetzt wieder auf die Canon CD zurück und versuchen Sie eine Installation, indem sie die setup.exe auf der CD starten. Wenn sie eine Netzfreigabe benutzen um Zugriff auf ein freigebenes DVD Laufwerk zu erhalten dauert die Installation ein wenig länger, es ist träger wenn sie die Installation über Netzfreigaben ausführen als wenn sie ein extern angeschlossenes DVD Laufwerk am USB Port benutzen. Windows 7 ist auch beim ersten Verbindungsversuch zu einem freigegeben Netzlaufwerk auf einem anderen Rechner recht lahm. Es werden die User Credentials (Anmeldeinformationen) des anderen Rechners abgefragt, d. h. sie müssen sich  mit den Login Daten Zugriff auf die Netzwerkressource verschaffen. Also haben sie bei dem Versuch Geduld. Ein paar Minuten warten löst so manches Problem von alleine. Wenn sie Aufforderung  zum Eingeben der User Credentials sehen sind sie schon ein gutes Stück weiter.Eventuell meckert die Installationsroutine nun über ein fehlendes Service Pack 1 von Microsoft. Ist dieses schon installiert können sie diesen Abschnitt überspringen. Dann haben sie die Automatischen Updates aktiviert. Falls nicht, und der Service Pack 1(SP1) ist noch nicht vorhanden müssen sie erst ein Windows Update ausführen. Danach müssen sie neu starten und die Installation erneut ausführen. Auch dann kann es vorkommen das die Canon Installationsroutine das SP1 nicht erkennt. Für den Fall müssen sie Windows 7 Starter komplett updaten, d.h. nachfolgende Service- und Sicherheitspatche von MS müssen noch eingespielt werden. Machen sie das Update Spiel, bis ihr Rechner aktuell ist und keine weiteren Updates benötigt werden. Dafür ist meist notwendig das sie den Rechner öfters neu starten. Ein kleines Geduldsspiel, aber ohne kommen wir nicht zum Ziel. Das Update mit SP1 und den folgenden KB-Patches kann schonmal mehrere Stunden in Anspruch nehmen. Alleine SP1 für 32bit Systeme ist etwas über 500Mb groß und durch die ständige Neustartetei geht schonmal eine Menge Zeit verloren. Jetzt sollte es möglich sein, die Software  zu installieren.
Schlimmstenfalls kommt erneut diese Meldung trotz installiertem SP1:

Problem Nummer 2: SP1 wird selbst nach der Installation nicht erkannt. Die Software lässt sich ohne nicht installieren!

Dann haben sie ein echtes Problem an dessen Lösung ich gerade arbeite. Brechen sie die Installation ab. Sie werden keinen Erfolg haben. Sobald ich die Lösung parat habe werde ich hier den Artikel erweitern. Hinterlassen sie einen Kommentar und ihre Email Adresse (mein name (at)meinedomain.de) falls sie benachrichtigt werden wollen.

1. UPDATE:

Alle Versuche die EOS Software auf die Starter Edition von Windows7 zur Installation zu bewegen schlagen fehl.  Auch ein Update auf Windows 7 Professionell brachte keinerlei Abhilfe! Hilfe!

 

 

 

 


Hinterlasse einen Kommentar

MS Zertifizierung Server 2008R2 und das MS Press Buch

Microsoft hinkt mal wieder hinterher. Man kann Zertifizierungen für Server 2008 ablegen, jedoch ist das von Microsoft Press angebotene Kursbuch nicht aktuell und basiert noch auf Server 2008 und nicht auf Release2. Die Prüfung 70-640 verlangt aber Stoff von R2.

Im Klartext heißt das, daß einiges an vermitteltem KnowHow nicht im Buch beschrieben ist. Das Vorbereiten auf die MS Prüfung 70-640 ist somit nicht ganz so einfach. Es muss zusätzlicher Stoff von R2 gebüffelt werden.

Der Galileo Verlag hat das aber schon vorbereitet und ein Buch für MS Server 2008R2 veröffentlicht. Zusätzlich gibt es einen kostenlosen Online Bereich in dem erweiterte Information über Server 2008R2 abgerufen werden können in Form eines openbook.

Danke Galileo! 🙂


3 Kommentare

Microsoft Windows Server 2008R2 x64 und die Suche nach einer funktionierenden Wlan Karte

Der Titel verrät es sofort. Hardwareprobleme.

Banale Probleme die mich viel Zeit gekostet haben, die mir keiner bezahlt. Und wenn ich mich so derart aufrege kommt meist ein profaner „die-firma-ist-doof“ – Artikel bei raus.

Der Beweggrund ist diesmal ein anderer. Aber erst mal zu dem speziellen Problem:

Windows Server 2008R2 von Microsoft ist in der 64-bit Version sehr bescheiden bestückt, wenn es um die Implementierung von WLAN Karten oder WLAN USB Sticks geht. Die mitgelieferten Treiber werden brav ignoriert, die Karte oder der Stick leuchtet munter, aber ist unbenutzbar.
Stundenlange Suche nach Chipsatztreibern im Internet lieferten einige alternativen Downloadlinks, aber kein Treiber war wirklich in der Lage das Gerät stabil zu im System zu starten. Ganz speziell war der erste Versuch eine 08/15 WLAN Karte von Linksys. Die WMP54G lieferte mir eine ganze Weile lang gute Dienste in einem Desktoprechner und nach dem Einbau in den Servertower war mir es nicht möglich entsprechende 64bit Treiber zu installieren. Diverse Webseiten verweisen auf RALINK Treiber der Serie 2500. Die taugen aber nix und es funktioniert nix. Weitere Treiber werden empfohlen…Ralink n61….etc etc….
Nachdem ich vier „ganz toll funktionierend gepriesene“- Treiber ausprobiert habe bin ich immer noch ohne WLAN. Dann ein Lichtblick, ich finde eine 64bit Installationsdatei des neuen Herstellers (Cisco Syst.) im Web. Beim Starten meckert die Installationroutine über den fehlenden WLAN Autoconfig Dienst von Windows. Der ist am Server über die Serverfeatures schnell aktiviert. Trotzdem erhalte ich weiter Fehlermeldungen über fehlende Dienste, die aber alle schon längst laufen.
Dann fällt mir noch ein DN 7003GV USB Stick in die Hände, der auch schonmal innerhalb meines Netzes funktionierte. Auch dort ist der 64bit Support scheinbar per Treiberupdate zu erreichen, aber unter der Serverversion von 2008R2 weigern sich die Treiber hartnäckig auch wenn sie unter Windows 7 x64 wunderbar arbeiten.

Also was tun? Es muss eine OS-kompatible Wlan Karte her aber welche. Nach 3 Stunden gegoogle habe ich nicht eine (!) Produktempfehlung seitens Microsoft entdecken können.
Für den Server2008R2 ist der Einsatz von Wlan Karten wohl nicht vorgesehen. Auch in der HCL steht nicht ein Adapter drin.
So bin ich denn auf zu meinen PC Dealer meines Vertrauens (hd-computer)und Chef persönlich hat mir nach drei Telefonaten eine TP-Link Wlan Karte mit zwei Antennen verkauft. „Die sollte gehen“…..den Spruch hör ich öfters…entsprechend skeptisch zahlte ich am Tresen 21 Euro für eine TP-Link 300Mps Wireless N PCI Adapter, Modell TL-WN851N und ging genauso skeptisch nach Hause.


Nach dem Einbau und dem ersten Start installierte das Betriebssystem brav die Treiber und die Karte war funktionsbereit. Das beiliegende Utility ist unter der Serverversion nicht lauffähig, aber die Verwaltung kann Windows übernehmen. Trotzdem war es notwendig einmal neu zu starten. Ohne Neustart verweigerte mir die Karte den Connect zum AccessPoint, obwohl ich alle Wi-Fi Netze sehen und auch auswählen konnte.

Und nach dem nächsten Neustart war ich im Netz.

Sollte es bei Ihnen nicht funktionieren, überprüfen Sie im Servermanager das Feature WLAN. Standardmäßig ist dieses Feature nicht installiert und der Dienst ist nicht aktiv. Daher kann die Karte nicht ordnungsgemäß funktionieren wenn der WLAN Dienst nicht läuft.

Nun ist das Szenario, einen Windows Server 2008R2 via WLAN ans Internet anzubinden nicht wirklich sinnvoll. In der Realität und im Produktionsbetrieb wird niemand auf diese Art und Weise verfahren. Trotzdem verstehe ich nicht wieso sich dieses Betriebssystem so schwer tut ein paar Adapter mehr zu unterstützen.

Falls sie einen WLAN Adapter PCI suchen der 100%ig mit Server 2008R2 funktioniert, dann kann ich den TP-Link TL-WN851N empfehlen. Probleme konnte ich bislang nicht feststellen. Im System kann ich sehen das es sich um einen Atheros Chipsatz handelt.. es könnte sein das Atheros auch einen 64bit fähiges Utility anbietet inzwischen.