Frischfisch

fish life reporting


Hinterlasse einen Kommentar

Win7: Firewalll lässt sich nicht starten (Fehler 0x8007042c)

Hier wieder ein Schnipsel zur Fehlerbehebung in Windows7. An einem Win7 pro war durch Malwarebefall selbst nach Bereinigung die Firewall nicht mehr zu starten. Bei dem Versuch die Einstellungen auf Standard zurück zu setzen erhält man die Fehlermeldung 0x8007042c.

fw1

Schaut man sich die Windows Dienste an und versucht den Windows Firewalldienst manuell zu starten erhält man ebenfalls eine Fehlermeldung:

fw2

Dieser Fehler 1068 zeigt eine fehlerhafte Abhängigkeit zu anderen Diensten. Laufen diese nicht kann der Firewalldienst grundsätzlich nicht alleine gestartet werden. In der Ereignisanzeige z. Bsp. oder in den Eigenschaften des Dienstes kann man sehen welche Abhängigkeiten bestehen.

fw3

Ein Blick in die Dienste zeigt mir das der Basisfilterdienst deaktiviert wurde. Die Einstellungen habe ich auf „automatischen Start“ geändert und den Dienst manuell gestartet. Danach ließ sich auch der Windows Firewall Dienst wieder regulär starten.

fw4

Advertisements


10 Kommentare

WIN7 – x64: Canon EOS 600D wird nicht erkannt

Normalerweise ist der Anschluss einer Digitalkamera an Windows 7 kein Problem. Die Treiberunterstützung unter Windows 7 ist gut, die meisten Geräte die man anschließt werden sofort erkannt und Windows installiert selbstständig die passenden Treiber falls es sie gibt.

Bei der 64bit Version kann es jedoch vorkommen das die Kamera nicht erkannt wird. Das kann mehrere Ursachen haben.

– Es ist Nokias PC Suite installiert, diese macht öfters mal Ärger und der Treiber für die USB Verbindung blockiert die korrekte Erkennung der Kamera. Achten Sie darauf das der Nokia Connectivity Cable Driver nicht läuft. Da ich gar kein Nokia mehr besitze habe ich die Software komplett entfernt. Geholfen hat es erstmal nicht, mein Problem lag viel tiefer.

– Benutzen sie das Originalkabel welches mit der Kamera geliefert wurde (Es wird von Canon so empfohlen, ich hatte nie Probleme mit USB Kabeln anderer Hersteller und halte das für Quatsch. USB ist USB und standard gefertigte Kabel sind identisch)

– Die Kamera wird nicht als EOS 600D sondern als MTP-USB-Device im Gerätemanager erkannt. Es erfolgt keine Erkennung. Das Gerät ist oft mit einem gelben Ausrufezeichen versehen. Der Treiber ist installiert (der Falsche!) und die Ausführung desTreibers erzeugt Konflikte im System weshalb das Gerät im System nicht gestartet werden kann.

– Bluetooth Treiber diverser Hersteller können auch mit den Canon Treibern kollidieren. Das passiert aber selten.

Nachdem ich nun Bluetooth Treiber deaktiviert hatte und die Nokia PC Suite entfernt hatte wurde die Kamera immer noch nicht erkannt. Bis zu diesem Zeitpunkt habe ich diverse Male neu gestartet, diverse Konfigurationsänderungen im System durchgeführt und alles probiert was man mir im Internet geraten hatte. Nichts hat geholfen. Was mich wunderte war die Tatsache das dieses Problem mal wieder nur bei mir auftritt. Mangels Beiträge in div. Foren erkannte ich das normalerweise keine derartigen Probleme bekannt sind. Die Treibereinbindung schien bei den meisten Nutzern einwandfrei zu funktionieren. Ein Grund mehr die Ursache zu finden.

Ich deinstallierte den MTP-USB Device aus dem Gerätemanager und führte die Hardwareerkennung aus. Wieder wird der MTP-USB Treiber installiert. Win7 erkennt die Kamera einfach nicht. In diversen Varianten habe ich versucht den falschen Treiber zu entfernen und die Hardwareerkennung erneut auszuführen. Ohne Erfolg. Ich habe eine neue Kamera und ein neues Notebook, das muss doch funktionieren!

Dann muss man wohl den administrativen Weg gehen und schaut erstmal in die Ereignisanzeige von Windows. Dort kann ich sehen das die Treiber installiert werden, das Gerät jedoch wegen Konflikten nicht gestartet werden kann. Außerdem ist es immer noch ein MTP-USB Gerät.In der Ereignisanzeige finde ich diverse Einträge die mit meinem Problem im Zusammenhang stehen:

Fehlerbucket 2491449066, Typ 5
Ereignisname: PnPDeviceProblemCode
Antwort: Nicht verfügbar
CAB-Datei-ID: 0

vorangegangen kam diese Meldung:

Fehlerbucket 1368950982, Typ 5
Ereignisname: PnPGenericDriverFound
Antwort: Nicht verfügbar
CAB-Datei-ID: 0

Der eigentliche Fehler ist aber hier zu finden:

Der Treiber für Gerät USB\VID_04A9&PID_3218&REV_0002 wurde erfolgreich installiert.

nächster Eintrag:

Auf das Gerät () konnte nach der Installation der Treiber nicht zugegriffen werden. Fehlercode 0x80070651.

Beim Fehlercode 0x80070651 kam mir dann die Idee in die Registrierung zu schauen. Die Hardware ID 04A9&PID_3218&REV_0002 war in der Registrierung schnell gefunden. Da kann nur einer dieser Filter schuld dran sein.

In dem Registrierungsschlüssel steht ein DWORD Wert der einen Upper Filter definiert. Dort ist der MTP-USB-Device eingetragen. Damit installiert Windows die Kamera immer als Portable Device. Ich habe den Eintrag gelöscht und siehe da beim nächsten Anschließen der Kamera wird sie korrekt erkannt, die Treiber werden sauber installiert und der Zugriff auf die Kamera funktioniert! Es wird als EOS 600D im Gerätemanager angezeigt, genau so wie es sein soll.

Dieser Fehler hat mich einen ganzen Tag gekostet. Es funktioniert nun aber der Zeitaufwand für die Fehlersuche war viel zu hoch. Es gibt sicher User die ihr Windows neu aufsetzen. Mein System ist zu komplex, Neuaufsetzen kam für mich nicht in Frage. Daher bin ich froh das ich die Ursache lokalisieren konnte.

[UPDATE] Es haben sich inzwischen noch weitere Lösungswege ergeben, da auch die Fehlerursache unterschiedlicher Natur sein kann. Hier: http://www.dslr-forum.de/showthread.php?t=1282695 kann man nachlesen wie dieser Benutzer das Problem gelöst hat.

[/UPDATE]


Hinterlasse einen Kommentar

Druckerprobleme Windows7 + MS Office – kein Druck möglich mit HP Officejet

Tja, der Microsoft eigene Treiber für die Officejets von HP funktionieren meist nicht. MS Office kann meist gar nicht drucken,  Browserinhalte drucken führt meist zum totalen „Freeze“ des Rechners. Ich hatte den Spooler in Verdacht… HP auch. Die haben für Win7 einen neuen Treiber gestrickt, den man auch tunlichst nutzen sollte. Danach läuft der Rechner sauber, der Drucker druckt und als Scanner scannt der OJ jetzt auch. Schön, das manche Probleme so einfach zu lösen sind. Also aktualisierten Treiber runterladen und feddisch.

zum Support von HP hier lang