Frischfisch

fish life reporting


2 Kommentare

Server 2008R2 – DNS Event ID 4013 – Server wartet auf Erstsynchronisierung

Als Admin stolpert man am Server häufiger mal über die Fehlermeldung 4013 in der Ereignisanzeige. Folgender Text schlägt einem entgegen:

Der DNS-Server wartet darauf, dass von den Active Directory-Domänendiensten angezeigt wird, dass die Erstsynchronisierung des Verzeichnisses durchgeführt wurde. Der DNS-Serverdienst kann erst nach der Erstsynchronisierung gestartet werden, da wichtige DNS-Daten möglicherweise noch nicht auf diesen Domänencontroller repliziert wurden. Sofern die im Ereignisprotokoll der Active Directory-Domänendienste protokollierten Ereignisse deutlich machen, dass Probleme bei der DNS-Namensauflösung vorliegen, sollte ggf. die IP-Adresse eines weiteren DNS-Servers für diese Domäne der DNS-Serverliste in den Internetprotokolleigenschaften dieses Computers hinzugefügt werden. Dieses Ereignis wird alle zwei Minuten protokolliert, bis von den Active Directory-Domänendiensten angezeigt wird, dass die Erstsynchronisierung durchgeführt wurde.

Nun läuft der Server schon einen Weile und nach jedem Neustart findet man diesen Eintrag erneut im Protokoll.

Abhilfe schafft ein verzögerter Start des DNS Dienstes. Damit hören die Fehlermeldungen auf.

Konfigurieren Sie unter den Diensten den DNS-Server Dienst mit einem automatischen verzögerten Start. (siehe Grafik)

Beim nächsten Neustart sollte die Fehlermeldung nicht mehr angezeigt werden.

DNS Fehler

DNS Fehler im Ereignislog

 

 

Es handelt sich hier um einen typischen Eventeintrag den niemand braucht. Der Fehler wird angezeigt weil ein Abhängigkeitsdienst noch nicht fertig gestartet hat während dieser Dienst zu starten will. Der verzögerte automatische Start löst diesen Konflikt. Auch bei einem normalen automatischen Start läuft der DNS Client fehlerfrei daher fällt dieser Eintrag erst auf wenn man ins Eventlog schaut.

Advertisements


3 Kommentare

Microsoft Windows Server 2008R2 x64 und die Suche nach einer funktionierenden Wlan Karte

Der Titel verrät es sofort. Hardwareprobleme.

Banale Probleme die mich viel Zeit gekostet haben, die mir keiner bezahlt. Und wenn ich mich so derart aufrege kommt meist ein profaner „die-firma-ist-doof“ – Artikel bei raus.

Der Beweggrund ist diesmal ein anderer. Aber erst mal zu dem speziellen Problem:

Windows Server 2008R2 von Microsoft ist in der 64-bit Version sehr bescheiden bestückt, wenn es um die Implementierung von WLAN Karten oder WLAN USB Sticks geht. Die mitgelieferten Treiber werden brav ignoriert, die Karte oder der Stick leuchtet munter, aber ist unbenutzbar.
Stundenlange Suche nach Chipsatztreibern im Internet lieferten einige alternativen Downloadlinks, aber kein Treiber war wirklich in der Lage das Gerät stabil zu im System zu starten. Ganz speziell war der erste Versuch eine 08/15 WLAN Karte von Linksys. Die WMP54G lieferte mir eine ganze Weile lang gute Dienste in einem Desktoprechner und nach dem Einbau in den Servertower war mir es nicht möglich entsprechende 64bit Treiber zu installieren. Diverse Webseiten verweisen auf RALINK Treiber der Serie 2500. Die taugen aber nix und es funktioniert nix. Weitere Treiber werden empfohlen…Ralink n61….etc etc….
Nachdem ich vier „ganz toll funktionierend gepriesene“- Treiber ausprobiert habe bin ich immer noch ohne WLAN. Dann ein Lichtblick, ich finde eine 64bit Installationsdatei des neuen Herstellers (Cisco Syst.) im Web. Beim Starten meckert die Installationroutine über den fehlenden WLAN Autoconfig Dienst von Windows. Der ist am Server über die Serverfeatures schnell aktiviert. Trotzdem erhalte ich weiter Fehlermeldungen über fehlende Dienste, die aber alle schon längst laufen.
Dann fällt mir noch ein DN 7003GV USB Stick in die Hände, der auch schonmal innerhalb meines Netzes funktionierte. Auch dort ist der 64bit Support scheinbar per Treiberupdate zu erreichen, aber unter der Serverversion von 2008R2 weigern sich die Treiber hartnäckig auch wenn sie unter Windows 7 x64 wunderbar arbeiten.

Also was tun? Es muss eine OS-kompatible Wlan Karte her aber welche. Nach 3 Stunden gegoogle habe ich nicht eine (!) Produktempfehlung seitens Microsoft entdecken können.
Für den Server2008R2 ist der Einsatz von Wlan Karten wohl nicht vorgesehen. Auch in der HCL steht nicht ein Adapter drin.
So bin ich denn auf zu meinen PC Dealer meines Vertrauens (hd-computer)und Chef persönlich hat mir nach drei Telefonaten eine TP-Link Wlan Karte mit zwei Antennen verkauft. „Die sollte gehen“…..den Spruch hör ich öfters…entsprechend skeptisch zahlte ich am Tresen 21 Euro für eine TP-Link 300Mps Wireless N PCI Adapter, Modell TL-WN851N und ging genauso skeptisch nach Hause.


Nach dem Einbau und dem ersten Start installierte das Betriebssystem brav die Treiber und die Karte war funktionsbereit. Das beiliegende Utility ist unter der Serverversion nicht lauffähig, aber die Verwaltung kann Windows übernehmen. Trotzdem war es notwendig einmal neu zu starten. Ohne Neustart verweigerte mir die Karte den Connect zum AccessPoint, obwohl ich alle Wi-Fi Netze sehen und auch auswählen konnte.

Und nach dem nächsten Neustart war ich im Netz.

Sollte es bei Ihnen nicht funktionieren, überprüfen Sie im Servermanager das Feature WLAN. Standardmäßig ist dieses Feature nicht installiert und der Dienst ist nicht aktiv. Daher kann die Karte nicht ordnungsgemäß funktionieren wenn der WLAN Dienst nicht läuft.

Nun ist das Szenario, einen Windows Server 2008R2 via WLAN ans Internet anzubinden nicht wirklich sinnvoll. In der Realität und im Produktionsbetrieb wird niemand auf diese Art und Weise verfahren. Trotzdem verstehe ich nicht wieso sich dieses Betriebssystem so schwer tut ein paar Adapter mehr zu unterstützen.

Falls sie einen WLAN Adapter PCI suchen der 100%ig mit Server 2008R2 funktioniert, dann kann ich den TP-Link TL-WN851N empfehlen. Probleme konnte ich bislang nicht feststellen. Im System kann ich sehen das es sich um einen Atheros Chipsatz handelt.. es könnte sein das Atheros auch einen 64bit fähiges Utility anbietet inzwischen.